CASCE is down
Incident Report for NC AHEC Program Status Page
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 14:46 EDT
Investigating
We are investigating the issue.
Posted Sep 22, 2023 - 14:03 EDT
This incident affected: CASCE/HCSETS/ORPCE (CASCE/HCSETS/ORPCE Application, CASCE/HCSETS Web Queries).