Online Course Completers Seeing Delayed Evaluations
Incident Report for NC AHEC Program Status Page
Resolved
This incident has been resolved.
Posted Sep 20, 2023 - 15:35 EDT
Investigating
We have been getting reports that some participants are not being notified that their evaluation is ready in a timely manner. The NC AHEC IT team is aware of the issue and has been working to determine next steps.

If you have been waiting more than 48 hours for access to your evaluation, please notify us at support@ncahec.net.

Thank you! We appreciate your patience as we work through this issue.
Posted Oct 14, 2022 - 16:52 EDT
This incident affected: Alchemer/Survey Gizmo (NC AHEC Evaluations Application).